$re = '/..(?=:..$)/is';
$str = '00:15:5D:73:48:01';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);