$re = '/^(?!.*?\.module).*\.css$/m';
$str = 'excellent/amaze.module.css
nothing/here.css
jake.css
jake.module.css
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);