re = /^(?!.*?\.module).*\.css$/m
str = 'excellent/amaze.module.css
nothing/here.css
jake.css
jake.module.css
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end