#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=(.*?\d){9,})(((((((00|\+)[0-9]{1,3}[ \-/]?)|0)[ ]?[1-9][0-9]{1,4})[ ]?[\-/]?[ ]?)|((((00|\+)[0-9]{1,3}[ ]?\()|\(0)(\)|[ ]?[1-9][0-9]{1,4}\))[ ]?[\-/]?[ ]?))[0-9]{1,7}([ \-/]?[0-9]{1,5}){0,4})"
Local $sString = "+33 (33) 3)44444444444 //the found string has only 5 digits, but it shouldn't be found because of (?=(.*?\d){9,})" & @CRLF & _
"+49123123123 //how can I exclude that, because there is no white space in the middle" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"// this is the part where I test all the other phone numbers, if you are interested in:" & @CRLF & _
"" & @CRLF & _
"//it should match these phone numbers:" & @CRLF & _
"testword +49 30 12345-67 testword " & @CRLF & _
"testword+49 (0)30 12345-67" & @CRLF & _
"(0)30 12345-67" & @CRLF & _
"(0)30 123 234" & @CRLF & _
"(0123)30 12345-67" & @CRLF & _
"test (021)30 123 234" & @CRLF & _
"s030 12345-67 dsd" & @CRLF & _
"(030) 12345 55 99testword " & @CRLF & _
"testword (030) 12345 44" & @CRLF & _
"0351 4640-123" & @CRLF & _
"09623 12 3 33" & @CRLF & _
"09234 1233" & @CRLF & _
"+49 123 1 2 12 31" & @CRLF & _
"0049 2123 1231" & @CRLF & _
"+1 3519 1231" & @CRLF & _
"0 30 / 12 34 56" & @CRLF & _
"0 30 / 12 34 56" & @CRLF & _
"030 / 12 34 56" & @CRLF & _
"0123 / 12312 123" & @CRLF & _
"testword 0178 1232231" & @CRLF & _
"+490 178 1232231" & @CRLF & _
"testword +36 (351)4740-991 testword" & @CRLF & _
"testword +36(351) 4740-991 testword" & @CRLF & _
"09623 12333 testword" & @CRLF & _
"" & @CRLF & _
"should NOT match (with the reason why it shouldn't match):" & @CRLF & _
"+49123123123 //because there is no white space" & @CRLF & _
"01781232231 //because there is no white space" & @CRLF & _
"123456 //because it doesn't have at least 9 digits and no white space" & @CRLF & _
"123.123 //because it has a dot" & @CRLF & _
"12-12-12 //because there is no white space and there is more than one dash" & @CRLF & _
"12-12 -12-12-12 //because there is more than one dash" & @CRLF & _
"1990 - 2000 //because it doesn't have at least 9 digits" & @CRLF & _
"1990-2000 //because it doesn't have at least 9 digits and no white space" & @CRLF & _
"1990-91 //because it doesn't have at least 9 digits and no white space" & @CRLF & _
"123 //because it doesn't have at least 9 digits and no white space" & @CRLF & _
"+36 (351) 47(40-991 //because it has more than one left bracket" & @CRLF & _
"+36 (33) 3)4444" & @CRLF & _
")40-991 //because it has more than one right bracket" & @CRLF & _
"+23+234 +2346 // because it has more than one plus sign" & @CRLF & _
"234 234 234 234 234 // because it has more than one white space in a row" & @CRLF & _
"123 123123 // because it has more than one white space in a row" & @CRLF & _
"01712123123" & @CRLF & _
"01234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")