const regex = /(?=(.*?\d){9,})(((((((00|\+)[0-9]{1,3}[ \-/]?)|0)[ ]?[1-9][0-9]{1,4})[ ]?[\-/]?[ ]?)|((((00|\+)[0-9]{1,3}[ ]?\()|\(0)(\)|[ ]?[1-9][0-9]{1,4}\))[ ]?[\-/]?[ ]?))[0-9]{1,7}([ \-/]?[0-9]{1,5}){0,4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(.*?\\d){9,})(((((((00|\\+)[0-9]{1,3}[ \\-\/]?)|0)[ ]?[1-9][0-9]{1,4})[ ]?[\\-\/]?[ ]?)|((((00|\\+)[0-9]{1,3}[ ]?\\()|\\(0)(\\)|[ ]?[1-9][0-9]{1,4}\\))[ ]?[\\-\/]?[ ]?))[0-9]{1,7}([ \\-\/]?[0-9]{1,5}){0,4})', 'g')
const str = `+33 (33) 3)44444444444 //the found string has only 5 digits, but it shouldn't be found because of (?=(.*?\\d){9,})
+49123123123 //how can I exclude that, because there is no white space in the middle
// this is the part where I test all the other phone numbers, if you are interested in:
//it should match these phone numbers:
testword +49 30 12345-67 testword
testword+49 (0)30 12345-67
(0)30 12345-67
(0)30 123 234
(0123)30 12345-67
test (021)30 123 234
s030 12345-67 dsd
(030) 12345 55 99testword
testword (030) 12345 44
0351 4640-123
09623 12 3 33
09234 1233
+49 123 1 2 12 31
0049 2123 1231
+1 3519 1231
0 30 / 12 34 56
0 30 / 12 34 56
030 / 12 34 56
0123 / 12312 123
testword 0178 1232231
+490 178 1232231
testword +36 (351)4740-991 testword
testword +36(351) 4740-991 testword
09623 12333 testword
should NOT match (with the reason why it shouldn't match):
+49123123123 //because there is no white space
01781232231 //because there is no white space
123456 //because it doesn't have at least 9 digits and no white space
123.123 //because it has a dot
12-12-12 //because there is no white space and there is more than one dash
12-12 -12-12-12 //because there is more than one dash
1990 - 2000 //because it doesn't have at least 9 digits
1990-2000 //because it doesn't have at least 9 digits and no white space
1990-91 //because it doesn't have at least 9 digits and no white space
123 //because it doesn't have at least 9 digits and no white space
+36 (351) 47(40-991 //because it has more than one left bracket
+36 (33) 3)4444
)40-991 //because it has more than one right bracket
+23+234 +2346 // because it has more than one plus sign
234 234 234 234 234 // because it has more than one white space in a row
123 123123 // because it has more than one white space in a row
01712123123
01234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}