re = /.*\/(infografik-kategorien)\/(.*)\/(?!.*term).*/m
str = 'https://test.ixtract.de/infografik-kategorien/prozess/'
subst = 'https://test.ixtract.de/Infografik-kategorien/$2/?term=$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result