import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!^)[ \\t]*\\r?\\n(?=\\$)";
final String string = "$index 57320 \n"
+ "$title The vertex-cover polynomial of a graph \n"
+ "$time 1988 \n"
+ "$abstract In this paper we define the vertex-cover... \n\n"
+ "$index 57321 \n"
+ "$title Locating stations on rapid transit lines \n"
+ "$time 1978 \n\n"
+ "$index 57322 \n"
+ "$title Fast heuristics for large scale covering-location problems \n"
+ "$time 1998 \n"
+ "$abstract We propose fast heuristics for large scale... \n\n"
+ "$index 57323 \n"
+ "$title Efficient vector processing on dataflow supercomputer SIGMA-1 \n"
+ "$time 2001 \n"
+ "$abstract Efficiency in vector handling is the key to obtaining high... ";
final String subst = ",";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}