# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\sF\d+.*?\n\n)\K(\n)"
test_str = ("A N K U N F T 11.08.15\n"
"*** NEUBUCHUNG ***\n"
" 11.08.15 xxx xxx X3 2830 14:25 17:50\n"
" 18.08.15 xxx xxx X3 2831 18:40\n"
" F882129 dsdsaidsaia\n"
" F882129 xxxyxyagydaysd\n\n\n\n"
"A N K U N F T 18.08.15\n"
"*** NEUBUCHUNG ***\n"
" 11.08.15 xxx xxx X3 2830 14:25 17:50\n"
" 18.08.15 xxx xxx X3 2831 18:40\n"
" F881554 ZXCXZCXCXZCCXZ\n"
" F881554 xcvcxvcxvcvxc\n"
" F881554 xvcxvcxcvxxvccvxxcv\n\n\n\n"
"11.08.15 xxx xxx X3 2830 14:25 17:50\n"
" 18.08.15 xxx xxx X3 2831 18:40\n"
" F881605 xczxcdfsfdsdfs\n"
" F881605 zxccxzxzdffdsfdx")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.