using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|(?<=[.?!]))\s*[A-Za-z,;'""\s]+\?";
string input = @"This is a string.Is this a question?What is the Question? I Dont know what the question is. Can you please list out the question?";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}