re = /(^|(?<=[.?!]))\s*[A-Za-z,;'"\s]+\?/i
str = 'This is a string.Is this a question?What is the Question? I Dont know what the question is. Can you please list out the question?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end