package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b([A-Z]{2})\b`)
var str = `The AA batteries. The CA power. The WV chronicles.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}