$re = '/\b([A-Z]{2})\b/';
$str = 'The AA batteries. The CA power. The WV chronicles.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);