$re = '/(?<=Device\s\=).*/m';
$str = 'Device = XYZ
Date = 123456
Time = 11:11:11
Sample Freqeuncy = 1000 mHz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);