re = /(?<=Device\s\=).*/m
str = 'Device = XYZ
Date = 123456
Time = 11:11:11
Sample Freqeuncy = 1000 mHz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end