const regex = /(?:^(?:\d+y)?(?:\d+m)?(?:\d+d)?$)|(?:not available)|(?:not applicable)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^(?:\\d+y)?(?:\\d+m)?(?:\\d+d)?$)|(?:not available)|(?:not applicable)', 'gm')
const str = `1
1d
1d
1d
1m
1m3d
1y5d
5y8m
1y3m4d
1y 3m 4d
not available
not applicable
not applicable hoppla
delicious sweets
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}