$re = '/(?:^(?:\d+y)?(?:\d+m)?(?:\d+d)?$)|(?:not available)|(?:not applicable)/m';
$str = '1
1d
1d
1d
1m
1m3d
1y5d
5y8m
1y3m4d
1y 3m 4d
not available
not applicable
not applicable hoppla
delicious sweets
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);