using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\^\(\w+(?:\|\w+)*\)\$";
string input = @"Should match:
^(100|500|1000)$
^(100)$
^(foo|bar)$
Shouldn't match:
^(foo|bar)[0-9]+$
^[0-9a-fA-F]+$
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}