$re = '/\^\(\w+(?:\|\w+)*\)\$/';
$str = 'Should match:
^(100|500|1000)$
^(100)$
^(foo|bar)$
Shouldn\'t match:
^(foo|bar)[0-9]+$
^[0-9a-fA-F]+$
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);