#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?smx)^CUT-FROM-" & @CRLF & _
"(?:(?:(?!CUT-(?:FROM-|TO)) . )++ | (?R))*?" & @CRLF & _
"^CUT-TO"
Local $sString = "CUT-FROM-A ..." & @CRLF & _
"CUT-FROM-B ..." & @CRLF & _
"CUT-TO ..." & @CRLF & _
"ignore" & @CRLF & _
"CUT-TO" & @CRLF & _
"apple" & @CRLF & _
"CUT-FROM-C ..." & @CRLF & _
"CUT-TO" & @CRLF & _
"orange" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")