$re = '/^CUT-FROM-
(?:(?:(?!CUT-(?:FROM-|TO)) . )++ | (?R))*?
^CUT-TO/smx';
$str = 'CUT-FROM-A ...
CUT-FROM-B ...
CUT-TO ...
ignore
CUT-TO
apple
CUT-FROM-C ...
CUT-TO
orange
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);