package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:BSSID +: (?<bssid>[a-z0-9]{2}(?::[a-z0-9]{2}){5}))|(?:Signal +: (?<signal>\d+)%)`)
var str = `There is 1 interface on the system:
Name : Wi-Fi
Description : Intel(R) Wi-Fi 6 AX201 160MHz
GUID : random_guid
Physical address : 36:fe:a6:54:12:b0
Interface type : Primary
State : connected
SSID : random_ssid
BSSID : 36:fe:a6:54:12:b0
Network type : Infrastructure
Radio type : 802.11ac
Authentication : WPA2-Personal
Cipher : CCMP
Connection mode : Auto Connect
Band : 5 GHz
Channel : 149
Receive rate (Mbps) : 866.7
Transmit rate (Mbps) : 780
Signal : 85%
Profile : random_profile`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}