import Foundation
let pattern = #"(?:BSSID +: (?<bssid>[a-z0-9]{2}(?::[a-z0-9]{2}){5}))|(?:Signal +: (?<signal>\d+)%)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
There is 1 interface on the system:
Name : Wi-Fi
Description : Intel(R) Wi-Fi 6 AX201 160MHz
GUID : random_guid
Physical address : 36:fe:a6:54:12:b0
Interface type : Primary
State : connected
SSID : random_ssid
BSSID : 36:fe:a6:54:12:b0
Network type : Infrastructure
Radio type : 802.11ac
Authentication : WPA2-Personal
Cipher : CCMP
Connection mode : Auto Connect
Band : 5 GHz
Channel : 149
Receive rate (Mbps) : 866.7
Transmit rate (Mbps) : 780
Signal : 85%
Profile : random_profile
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)