const regex = new RegExp('^.*_(.*)\\.csv$', 'mg')
const str = `Varying Concentration2_20190712-145158_Base Media.csv
Varying Concentration2_20190712-145158_250 g per l.csv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}