// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*_(.*)\.csv$").unwrap();
let string = "Varying Concentration2_20190712-145158_Base Media.csv
Varying Concentration2_20190712-145158_250 g per l.csv";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}