const regex = /^---+(?!(?:\r?\n.*iDontWant.*$)+\r?\n---+$)(?:\r?\n.*$)+?(?=\r?\n---+$|\Z)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^---+(?!(?:\\r?\\n.*iDontWant.*$)+\\r?\\n---+$)(?:\\r?\\n.*$)+?(?=\\r?\\n---+$|\\Z)', 'gm')
const str = `---------------------------------------------
someRandomFile.php A:\\iWant\\someFolder
someRandomFile.php A:\\iWant\\someFolder
someRandomFile.php A:\\iWant\\someFolder
---------------------------------------------
someRandomFile.php A:\\iDontWant\\someFolder
someRandomFile.php A:\\iDontWant\\someFolder
---------------------------------------------
someRandomFile.xml A:\\iWant\\someFolder
someRandomFile.xml A:\\iWant\\someFolder
---------------------------------------------
someRandomFile.xml A:\\iDontWant\\someFolder
someRandomFile.xml A:\\butWathever\\someFolder
---------------------------------------------
someRandomFile.xml A:\\iWant\\someFolder
someRandomFile.xml A:\\iWant\\someFolder
---------------------------------------------`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}