$re = '/^---+(?!(?:\r?\n.*iDontWant.*$)+\r?\n---+$)(?:\r?\n.*$)+?(?=\r?\n---+$|\Z)/m';
$str = '---------------------------------------------
someRandomFile.php A:\\iWant\\someFolder
someRandomFile.php A:\\iWant\\someFolder
someRandomFile.php A:\\iWant\\someFolder
---------------------------------------------
someRandomFile.php A:\\iDontWant\\someFolder
someRandomFile.php A:\\iDontWant\\someFolder
---------------------------------------------
someRandomFile.xml A:\\iWant\\someFolder
someRandomFile.xml A:\\iWant\\someFolder
---------------------------------------------
someRandomFile.xml A:\\iDontWant\\someFolder
someRandomFile.xml A:\\butWathever\\someFolder
---------------------------------------------
someRandomFile.xml A:\\iWant\\someFolder
someRandomFile.xml A:\\iWant\\someFolder
---------------------------------------------';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);