package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(FROM ).*?( TO)`)
var str = `This is my string that I need to replace a part FROM to a part TO.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}