$re = '/(FROM ).*?( TO)/';
$str = 'This is my string that I need to replace a part FROM to a part TO.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);