import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*\\b(?:one|two|three|four|five|six|seven|eight|nine)\\b)(\\b(?:one|two|three)(?:\\s+(?:one|two|three))*\\b)?.+?(\\b(?:four|five|six)(?:\\s+(?:four|five|six))*\\b)?.+?(\\b(?:seven|eight|nine)(?:\\s+(?:seven|eight|nine))*\\b)?";
final String string = "one two three four five six seven eight nine\n\n"
+ "two three four \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}