const regex = /(?=.*\b(?:one|two|three|four|five|six|seven|eight|nine)\b)(\b(?:one|two|three)(?:\s+(?:one|two|three))*\b)?.+?(\b(?:four|five|six)(?:\s+(?:four|five|six))*\b)?.+?(\b(?:seven|eight|nine)(?:\s+(?:seven|eight|nine))*\b)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*\\b(?:one|two|three|four|five|six|seven|eight|nine)\\b)(\\b(?:one|two|three)(?:\\s+(?:one|two|three))*\\b)?.+?(\\b(?:four|five|six)(?:\\s+(?:four|five|six))*\\b)?.+?(\\b(?:seven|eight|nine)(?:\\s+(?:seven|eight|nine))*\\b)?', 'gm')
const str = `one two three four five six seven eight nine
two three four
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}