#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<!-- build-remove-start -->[\s\S]<!-- build-remove-end -->"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html lang="en">" & @CRLF & _
"<head>" & @CRLF & _
" <meta charset="UTF-8">" & @CRLF & _
" <title>Hello</title>" & @CRLF & _
" <!-- bower:css -->" & @CRLF & _
" <!-- endbower -->" & @CRLF & _
"" & @CRLF & _
" <!-- inject:css -->" & @CRLF & _
" <!-- endinject -->" & @CRLF & _
"</head>" & @CRLF & _
"<body>" & @CRLF & _
"<h1>Hello World!</h1>" & @CRLF & _
"" & @CRLF & _
"<!-- build-remove-start -->" & @CRLF & _
"<!-- bower:js -->" & @CRLF & _
"<script src="../bower_components/jquery/dist/jquery.js"></script>" & @CRLF & _
"<!-- endbower -->" & @CRLF & _
"<!-- build-remove-end -->" & @CRLF & _
"" & @CRLF & _
"<!-- inject:vendor:js -->" & @CRLF & _
"<!-- endinject -->" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<!-- inject:js -->" & @CRLF & _
"<!-- endinject -->" & @CRLF & _
"" & @CRLF & _
"<!-- inject:app:js -->" & @CRLF & _
"<!-- endinject -->" & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")