// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<!-- build-remove-start -->[\s\S]<!-- build-remove-end -->").unwrap();
let string = "<!DOCTYPE html>
<html lang=\"en\">
<head>
<meta charset=\"UTF-8\">
<title>Hello</title>
<!-- bower:css -->
<!-- endbower -->
<!-- inject:css -->
<!-- endinject -->
</head>
<body>
<h1>Hello World!</h1>
<!-- build-remove-start -->
<!-- bower:js -->
<script src=\"../bower_components/jquery/dist/jquery.js\"></script>
<!-- endbower -->
<!-- build-remove-end -->
<!-- inject:vendor:js -->
<!-- endinject -->
<!-- inject:js -->
<!-- endinject -->
<!-- inject:app:js -->
<!-- endinject -->
</body>
</html>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}