const regex = /^( *|\t*)func\s(\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^( *|\\t*)func\\s(\\w+)', 'gm')
const str = ` func showProductsList(result: UserResult<[Product]>) {
}
func showFetchNextSliceFailed(result: UserResult<[Product]>) {
}`;
const subst = `\1#Mark \2\n\1func \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);