$re = '/^( *|\t*)func\s(\w+)/m';
$str = ' func showProductsList(result: UserResult<[Product]>) {
}
func showFetchNextSliceFailed(result: UserResult<[Product]>) {
}';
$subst = "\1#Mark \2\n\1func \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;