import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:city|route)=(\\w+)(?:\\(|\\-)(\\w+)(?:\\,|\\;)(\\w+)";
final String string = "city=A(100,80);\n"
+ "city=B(160,70);\n"
+ "city=C(110,50);\n"
+ "city=D(140,120);\n"
+ "city=F(155,40);\n"
+ "city=G(210,60);\n"
+ "city=H(190,10);\n"
+ "city=I(170,110);\n"
+ "route=A-C;140;\n"
+ "route=A-D;155;\n"
+ "route=C-F;125;\n"
+ "route=D-B;115;\n"
+ "route=D-I;152;\n"
+ "route=B-F;119;\n"
+ "route=B-G;136;\n"
+ "route=G-F;133;\n"
+ "route=F-H;163;\n"
+ "route=I-H;197;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}