package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[<>]?(\d{1,3})(,?1)$`)
var str = `4.125.583`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}