$re = '/-(?=\d)/';
$str = 'About -38% is made with this-and also with something else.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);