re = /-(?=\d)/
str = 'About -38% is made with this-and also with something else.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end