$re = '~^/content/([^/]*)/([^/]*)/([^/]*)/(?![^/]*/(?:sample1|sample2))([^/]*)~m';
$str = '/content/atm/en/marketing/royalty/sometext
/content/atm/en/marketing/royalty/sample1
/content/atm/en/marketing/royalty/sometext
/content/atm/en/marketing/royalty/sometext
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);