re = /^\/content\/([^\/]*)\/([^\/]*)\/([^\/]*)\/(?![^\/]*\/(?:sample1|sample2))([^\/]*)/m
str = '/content/atm/en/marketing/royalty/sometext
/content/atm/en/marketing/royalty/sample1
/content/atm/en/marketing/royalty/sometext
/content/atm/en/marketing/royalty/sometext
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end