using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^domain\.com/bikes/([^\/]+)/([^\/]+?)$";
string input = @"domain.com/bikes/pink/washington
domain.com/bikes/red/washington
domain.com/bikes/blue-green/alabama";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}