// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^domain\.com/bikes/([^\/]+)/([^\/]+?)$").unwrap();
let string = "domain.com/bikes/pink/washington
domain.com/bikes/red/washington
domain.com/bikes/blue-green/alabama";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}