import re
regex = re.compile(r"\/[^/]+$", flags=re.MULTILINE)
test_str = ("/docs/one_of_the_resources/one-of-the-resources.html\n"
"/docs/a_complete_different_resource/a-complete-different-resource.html")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")