import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"[^\"]+\"[^\"]+?)?(\\bdog\\b)";
final String string = "Dog sighed. \"I'm no super dog, nor special dog,\" said Dog, \"I'm an ordinary dog, now leave me alone!\" Dog pushed him away and made his way to the other dog.";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}