// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)(?:"[^"]+"[^"]+?)?(\bdog\b)"#).unwrap();
let string = "Dog sighed. \"I'm no super dog, nor special dog,\" said Dog, \"I'm an ordinary dog, now leave me alone!\" Dog pushed him away and made his way to the other dog.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}