import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">Title.*?(?=<td>)<td>\\K.*?(?=<\\/td>)";
final String string = "<table> \n"
+ " <tr>\n"
+ " <td>Title</td>\n"
+ " <td>The Harsh Face of Mother Nature</td>\n"
+ " <td>The Harsh Face of Mother Nature</td>\n"
+ " </tr>\n"
+ " .\n"
+ " .\n"
+ " .\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}