const regex = />Title.*?(?=<td>)<td>\K.*?(?=<\/td>)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('>Title.*?(?=<td>)<td>\\K.*?(?=<\\\/td>)', 'gs')
const str = `<table>
<tr>
<td>Title</td>
<td>The Harsh Face of Mother Nature</td>
<td>The Harsh Face of Mother Nature</td>
</tr>
.
.
.
</table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}