package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w.]+=\$(?:\d|1[012])(?:\|[\w.]+=\$(?:\d|1[012]))*$`)
var str = `Valid Values:
ABC=$2|CDE=$1|Msg=$4|Ph.No=$3|TIME=$5
ABC=$2|CDE=$1|Msg123=$4|Ph.No=$3|TIME_23=$5
abc=$2|123=$1|cfg=$4|Ph.No=$3
ABC=$12|CDE=$1|Msg=$12|Ph.No=$11|TIME=$5
ABC=$12|CDE=$6|Msg123=$9|Ph.No=$3|TIME_23=$10
Invalid Values:
ABC=$2CDE=$1Msg=$4
ABC=2|CDE=1|Msg123=$4|Ph.No=$3|TIME_23=$5
abc$2|123$1|cfg$4|Ph.No=$3
Msg123=$ |Ph.No=$ |TIME_23=5
abcdefgh|1234|eghjik
Msg123=$*|Ph.No=$()|TIME_23=$5
Msg123=$a|Ph.No=$b|TIME_23=$p`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}